Wednesday, December 25, 2013

New Configuration for Mikrotik

Ether1= wan interface
Ether3 = lan interface

/ip firewall mangle

add action=mark-connection chain=prerouting comment="manipulasi Type of Service untuk ICMP Packet" disabled=no in-interface=ether3 new-connection-mark=ICMP-CM passthrough=yes protocol=icmp
add action=mark-packet chain=forward comment="" connection-mark=ICMP-CM disabled=no new-packet-mark=ICMP-PM out-interface=ether3 passthrough=yes
add action=change-dscp chain=prerouting comment="" disabled=no new-dscp=16 packet-mark=ICMP-PM
add action=mark-connection chain=prerouting comment="manipulasi Type of Service untuk DNS Resolving" disabled=no dst-port=53 in-interface=ether3 new-connection-mark=DNS-CM passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=53 in-interface=ether3 new-connection-mark=DNS-CM passthrough=yes protocol=udp
add action=mark-packet chain=prerouting comment="" connection-mark=DNS-CM disabled=no in-interface=ether3 new-packet-mark=DNS-PM passthrough=yes
add action=change-dscp chain=prerouting comment="" disabled=no new-dscp=16 packet-mark=DNS-PM
add action=mark-connection chain=prerouting comment=browsing disabled=no in-interface=ether1 new-connection-mark=browsing passthrough=yes protocol=tcp src-port=21,80,443
add action=mark-packet chain=prerouting comment="" connection-mark=browsing disabled=no in-interface=ether1 new-packet-mark=browsing passthrough=no
add action=mark-connection chain=prerouting comment="Dragon Nest" disabled=no dst-port=15100-15150,14101 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=14300-14501 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=PointBlank disabled=no dst-port=39100,39110,39220,39190,49100 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=40000-40010 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="El Sword" disabled=no dst-port=9300-9310 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=9101-9105 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="Lost Saga" disabled=no dst-port=14009,14010 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=14009-14026 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=PW disabled=no dst-port=29000 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="S4 League" disabled=no dst-port=54500-56500 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=16666-16668,28000-28013 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment="special force" disabled=no dst-port=30000-30010 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=Atlantica disabled=no dst-port=4300 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="CS online" disabled=no dst-port=36567,8001 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=8001,41400-41932, 42105 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=marble disabled=no dst-port=28900-28915 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="3 Kingdom" disabled=no dst-port=42051-42052 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-connection chain=prerouting comment=DOTA disabled=no dst-port=6000-6605,10110-10500 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=RF disabled=no dst-port=27780 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Idolstreet disabled=no dst-port=2001 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=Ayodance disabled=no dst-port=18901-18909 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment=HON disabled=no dst-port=11031 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting comment="" disabled=no dst-port=11235-11335 in-interface=ether3 new-connection-mark=game passthrough=yes protocol=udp
add action=mark-packet chain=forward comment="mark packet game_down" connection-mark=game disabled=no new-packet-mark=game_down out-interface=ether3 passthrough=yes
add action=mark-packet chain=prerouting comment="mark packet game_up" connection-mark=game disabled=no in-interface=ether3 new-packet-mark=game_up passthrough=no
add action=mark-connection chain=output comment=winbox disabled=no new-connection-mark=winbox out-interface=ether3 passthrough=yes protocol=tcp src-port=8291
add action=mark-packet chain=output comment="" connection-mark=winbox disabled=no new-packet-mark=winbox_packet out-interface=ether3 passthrough=no

/queue type
add kind=pcq name=upstream pcq-classifier=src-address pcq-limit=50 pcq-rate=0 pcq-total-limit=2000
add kind=pcq name=downstream pcq-classifier=dst-address pcq-limit=50 pcq-rate=0 pcq-total-limit=2000
add kind=pfifo name=pfifo-64 pfifo-limit=64

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=8k max-limit=100k name=ICMP packet-mark=ICMP-PM parent=global-out priority=1 queue=pfifo-64
add burst-limit=100k burst-threshold=100k burst-time=10s disabled=no limit-at=8k max-limit=100k name=DNS packet-mark=DNS-PM parent=global-in priority=1 queue=pfifo-64
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=winbox packet-mark=winbox_packet parent=global-out priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=500k max-limit=500k name=gameup packet-mark=game_up parent=global-in priority=1 queue=upstream
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=500k max-limit=1M name=gamedown packet-mark=game_down parent=global-out priority=1 queue=downstream
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2300k name=browsing packet-mark=browsing parent=global-in priority=8 queue=upstream

No comments:

Post a Comment