Wednesday, December 28, 2011

Marking Koneksi game facebook di mikrotik

Marking disini saya gunakan pada mikrotik tanpa load balancing, karena ketika saya gabungkan dengan load balancing terjadi error pada koneksi.

Berikut command2nya :

/ ip firewall mangle

add chain=prerouting protocol=tcp content=cdn.static.ninjasaga.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="ninja saga" disabled=no

add chain=prerouting protocol=tcp content=empire-zc.static.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="empire and allies" disabled=no

add chain=prerouting protocol=tcp content=hs.llnwd.net action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="mafia wars" disabled=no


add chain=prerouting protocol=tcp content=statics.poker.static.zynga.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="poker" disabled=no

add chain=prerouting protocol=tcp content=static-cdn.playfish.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="the sims" disabled=no

add chain=prerouting protocol=tcp content=cloudfront.net action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=cityvillefb0.static.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="cityville" disabled=no

add chain=prerouting protocol=tcp content=cityvillefb1.static.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=cityvillefb2.static.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=mw2.static1.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="mafia wars 2" disabled=no

add chain=prerouting protocol=tcp content=mw2.static2.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=mw2.static3.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=mw2.static.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="" disabled=no

add chain=prerouting protocol=tcp content=static.farmville.zgncdn.com action=mark-connection new-connection-mark=facebook_game passthrough=yes comment="farmvillle" disabled=no

add chain=prerouting connection-mark=facebook_game action=mark-packet new-packet-mark=facebook_game passthrough=no comment="" disabled=no

add chain=prerouting protocol=tcp connection-mark=!facebook_game action=mark-connection new-connection-mark=koneksi passthrough=yes comment="koneksi diluar game facebook" disabled=no

add chain=prerouting protocol=udp connection-mark=!facebook_game action=mark-connection new-connection-mark=koneksi passthrough=yes comment="" disabled=no

add chain=prerouting connection-mark=koneksi action=mark-packet new-packet-mark=koneksi passthrough=no comment="" disabled=no

Untuk melimitnya dapat digunakan queue tree atau queue simple

Pada Queue Tree
Terlebih dahulu buat queue typenya
/queue type 
add kind=pcq name=downstream-pcq pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=20000

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s comment="game facebook" disabled=no limit-at=128000 max-limit=1000000 name=game_facebook packet-mark=facebook_game parent=global-out priority=8 queue=downstream-pcq

Pada Queue Simple

/queue simple
add name="facebook_game" target-addresses=192.168.1.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=facebook_game direction=both priority=8 queue=default-small/default-small limit-at=128000/128000 max-limit=256000/1000000 total-queue=default-small disabled=no

Dibawah ini adalah settingan bandwitdh untuk client :
/queue simple
add name="residentnet" dst-address=0.0.0.0/0 interface=all parent=none packet-marks=koneksi direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=605000/2000000 total-queue=default-small disabled=no

add name="billing" target-addresses=192.168.1.2/32 dst-address=0.0.0.0/0 interface=all parent=residentnet packet-marks=koneksi direction=both priority=3 queue=default-small/default-small limit-at=40000/136000 max-limit=256000/300000 total-queue=default-small disabled=no

add name="kom1" target-addresses=192.168.1.3/32 dst-address=0.0.0.0/0 interface=all parent=residentnet packet-marks=koneksi direction=both priority=3 queue=default-small/default-small limit-at=40000/136000 max-limit=256000/300000 total-queue=default-small disabled=yes

add name="kom2" target-addresses=192.168.1.4/32 dst-address=0.0.0.0/0 interface=all parent=residentnet packet-marks=koneksi direction=both priority=3 queue=default-small/default-small limit-at=40000/136000 max-limit=256000/300000 total-queue=default-small disabled=yes

add name="kom3" target-addresses=192.168.1.5/32 dst-address=0.0.0.0/0 interface=all parent=residentnet packet-marks=koneksi direction=both priority=3 queue=default-small/default-small limit-at=40000/136000 max-limit=256000/300000 total-queue=default-small disabled=no

Selamat Mencoba

1 comment: